Skip to main content

GurobiError: HostID mismatch (licensed to 5dc163b3, hostid is 5dc16bc8) in WSL

Answered

Comments

10 comments

  • Dan Steffy
    Gurobi Staff Gurobi Staff

    Hello Vigneshwaran, 

    Thank you for posting your question. You are getting this error because each standard free academic license is associated with a specific HostID. However, rebooting your machine can change the HostID within WSL. Instructions for setting up Gurobi in WSL2 can be found in the following article:

    How do I set up Gurobi in WSL2 (Windows Subsystem for Linux)?

    I hope that this article helps you solve your problem. If you are still experiencing issues with your license and installation after following these instructions, you may open a support request through the Gurobi Help Center.

    Thanks,

    -Dan

    0
  • vigneshwaran kannan
    Gurobi-versary
    Curious
    Conversationalist

    What is a floating license?  I am using Gurobi 9.5 and wls (floating license) academic license for WSL is only for Gurobi version 10. 

    0
  • lucas parada

    Hello, 

    Same problem here with WSL.

    From the article "Option 2: Using an single-machine individual Gurobi License" where can I find the information for the grbgetkey command?

    grbgetkey xxxxxx-xxxx-xxxx-xxxx-xxxxxxxx --input wsl2-hostinfo.txt

    The user portal does not have the string to call the command.

    0
  • Matthias Miltenberger
    Gurobi Staff Gurobi Staff

    Just in case someone else faces the same problem:

    On the Licenses page in the user portal, you should see your licenses. You should also see an "Install" button on the right. Clicking this should show you the code for the grbgetkey command.

    Cheers,
    Matthias

    0
  • Alexander Hoogsteyn
    First Comment

    Hi,

    I am encountering a similar problem, when trying to renew my yearly academic license. I received the message that there is a HostID mismatch because licensed to b3f45c83 but the host id is d34c7403, I verified that "b3f45c83" indeed is the host id of my new license but the host id  "d34c7403" is unknown to me (it is not my previous host id).

    I tried asking for a WSL license, which functioned, but it does not offer enough workers for my application.

     

    Kind regards,

    Alexander

    0
  • Eli Towle
    Gurobi Staff Gurobi Staff

    Are you using WSL2? If so, have you tried following the instructions for "Using a single-machine individual Gurobi license" described in the How do I set up Gurobi in WSL2 (Windows Subsystem for Linux)? article?

    0
  • Alexander Hoogsteyn
    First Comment

    I am trying to use the single machine license. I tried using a WSL license instead, which resolved the licensing problem, but it does not offer enough workers for my application.

    0
  • Marika Karbstein
    Gurobi Staff Gurobi Staff

    Please note that an academic named user license is tied to a certain machine. It cannot be easily used on  Windows Subsystem Linux - WSL2 because the MAC address changes upon rebooting. That's why Eli pointed you to the article How do I set up Gurobi in WSL2 (Windows Subsystem for Linux)? 
    If you are not tryng to use a named user license in WLS2 then please give more details on what you are trying to do and what issues you face.
    The article What system changes can invalidate a license file? might also be helpful.

    0
  • Gwyneth Butera
    Gurobi Staff Gurobi Staff

    If your WLS license does not provide enough sessions, please open a support request describing the situation so we can further assist you.

    0
  • Alexander Hoogsteyn
    First Comment

    I should have mentioned that I am using a high-performance cluster to execute my program. It appears that the host ID mismatch occurred since I was starting the execution of my program from a different Linux terminal than the one on which the program is executed, due to how execution is scheduled on the high-performance cluster I use.

    Setting up the terminal from which I started executing as a token server resolved my problem and allowed me to continue using the single named license. Thanks for the help!

    0

Please sign in to leave a comment.