Skip to main content

problem infeasible or unbounded

Ongoing

Comments

2 comments

  • Simranjit Kaur
    Gurobi Staff Gurobi Staff

    Hi Iason,

    You can start by first determining if your model is infeasible or unbounded. Please see the article How do I resolve the error "Model is infeasible or unbounded"? for more details.

    If the model is infeasible, you can run the computeIIS method on your model to examine why your model is infeasible. It will provide a minimal subset of constraints and variable bounds that, if isolated from the rest of the model, is still infeasible. Please see the article How do I determine why my model is infeasible for more details.

    In addition to this, the warning message in the log indicates that your model has numerical issues. There is a wide range of coefficients in the matrix. For the range of the matrix coefficients, we recommend no more than 6 orders of magnitude in the difference between the min and max coefficient values.

    It may be helpful to reformulate the model to improve the numerical properties as discussed in the Gurobi Guidelines for Numerical Issues.

    Best regards,

    Simran

    0
  • Iason Liagkas
    Thought Leader
    Investigator

    Hi Simranjit,

    I can run the code: 

    for c in model.getConstrs():
        print(c.IISConstr)


    But I cannot run:

    for c in model.getConstrs():
        print(c.IISQConstr)

    OR

    for c in model.getConstrs():
        print(c.IISGenConstr)


    The only difference between those codes is the name of the attribute. Is there any reason that I can get only the included constraints but not the quadratic/general ones? The log says It includes 17 constraints but I see only 13 printed by the code:

    for c in model.getConstrs():
            if c.IISConstr:
                print('%s' % c.constrName)

     Also, another thing I have noticed is that 17 are the IIS constraints when I run my code on Gurobi 10. When I run my code on Gurobi 9.1 I have 1569 IIS constraints. Is this some kind of Gurobi 10 Bug? 

    Kind regards
    Iason

     

    0

Please sign in to leave a comment.