Skip to main content

GAP falls slowly



1 comment

  • Jaromił Najman
    Gurobi Staff Gurobi Staff

     The idea of ​​this problem is to tune the parameters as little as possible, any other recommendations?

    The difference in coefficient range of your matrix is 14 orders of magnitude

    Matrix range     [2e-06, 2e+08]

    I see that you are using the NumericFocus parameter, but it would be a lot better to try to re-scale the model by hand in order to reduce the coefficient range. This should be the best way to improve performance for your model. For more information please refer to our Guidelines for Numerical Issues.

    Setting the PerturbValue seems strange to me. Is it really required? I would guess that once you re-scaled your model it should not be needed.

    You could set the Method to 2 in order to always use Barrier as it seems to be best here. This should save some time.

    It might make sense to experiment with the NoRelHeurTime parameter which activates the No Relaxation heuristics. This particular heuristics searches for a feasible point even before solving the root node relaxation.

    Maybe experimenting with the MIPFocus parameter might help as well.

    Please refer to our documentation of the Most important parameters for more inspiration.

    Best regards, 


Please sign in to leave a comment.