Skip to main content

Getting Stuck in gap in MIP optimization model

Answered

Comments

1 comment

  • Maliheh Aramon
    Gurobi Staff Gurobi Staff

    Hi Atefeh, 

    There are so many parameters at non-default values. What is the reasoning behind setting all these parameters?

    We would suggest first running your model with the default setting. You can then examine the Gurobi log to understand why the gap does not improve. Is it because of the slow progress in the incumbent or in the best bound? If it is the former, you can experiment with parameters such as MIPFocus=1, NoRelHeurTime, Heuristics, and Cuts=0|1. If it is the latter, you can experiment with parameters such as Presolve=2, MIPFocus=2|3, and Cuts=2|3.

    Experimenting with different values of the Method parameter generally makes sense if the time it takes to solve the root relaxation is considerably high. 

    Experimenting with the PreSOS1BigM parameter makes sense if you have used any of Gurobi APIs to model simple general constraints such as min, max, and abs.

    Experimenting with the ScaleFlag parameter typically makes sense if the log shows signs of numerical difficulties or if the final solution quality is not acceptable. 

    Tightening the default tolerance values such as FeasibilityTol, OptimalityTol, and IntFeasTol is not recommended unless there is a good reason. For example, if the smallest coefficient values in your model are in the order of 1e-7, it makes sense to set the FeasibilityTol, OptimalityTol to 1e-8 (an order of magnitude smaller).

    Best regards,

    Maliheh

    0

Please sign in to leave a comment.