Gurobi applies heuristics even after turning them off

Ongoing

Comments

5 comments

  • Gwyneth Butera

    Hi Nico - Can you share the log of your optimization run?

    Thanks!

    0
    Comment actions Permalink
  • Nico André Schmid

    Sure, I am adding a Screenshot here. But if needed, I can also send you the entire logfile. I marked the place, where a heuristic solution has been found according to the log. I also set GRB_IntParam_NoRelHeuristic to 0 as you suggested in your email.

     

    0
    Comment actions Permalink
  • Gwyneth Butera

    Some of these don't apply to the log you shared, but what happens when you set all these parameters to 0?

    MinRelNodes    Minimum relaxation heuristic control
    PartitionPlace    Controls when the partition heuristic runs
    PumpPasses    Feasibility pump heuristic control
    RINS    RINS heuristic
    SubMIPNodes    Nodes explored by sub-MIP heuristics
    ZeroObjNodes    Zero objective heuristic control
    0
    Comment actions Permalink
  • Nico André Schmid

    I have tried that as well and still heuristics are shown in the log.

    0
    Comment actions Permalink
  • Eli Towle

    Hi,

    With heuristics disabled, Gurobi spends no time actively looking for heuristic solutions. However, it could happen that Gurobi still encounters solutions as part of its solving process, even without devoting any additional meaningful work to finding them. These are reported as heuristic solutions.

    Thanks,

    Eli

    1
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk