Skip to main content

username field cannot be blank

Answered

Comments

8 comments

  • Marika Karbstein
    Gurobi Staff Gurobi Staff

    We have seen this issue before when installing Gurobi from conda, this makes Gurobi not able to retrieve your username. Leading grbgetkey and grbprobe to fail.

    Could you please try installing the full version of Gurobi? You may also use the package that only contains the licensing tools: How do I set up a license without installing the full Gurobi package? – Gurobi Support Portal

    -1
  • wentao zou
    Gurobi-versary
    First Comment
    First Question

    I got this version from https://www.gurobi.com/downloads/gurobi-software/ .

    I think it is the full version, and I also try to run grbprobe download from the package that only contains the licensing tools. The user name is still blank.

    1
  • Marika Karbstein
    Gurobi Staff Gurobi Staff

    Can you please confirm whether you use an Anaconda environment?
    If so could you please run conda list and check whether there is an entry called krb5?
    You may need to install this if it's not there.

    -1
  • Onur Can Saka
    Gurobi-versary
    First Comment

    Hello,

    I am having the same issue when trying to upgrade my token server from v9.5.2 to v10.0.0. I am not using conda. I tried downloading both the full version and the license tools only, but in either case I get the following message when I try to obtain the license file with grbgetkey

    Are there any other solutions you would recommend?
    Thanks.

    1
  • Nils Alexandersson
    Gurobi-versary
    First Comment

    I also have the same issue, and haven't solved it working on it for several hours. 
    I use Linux Open Suse Tumbleweed, using the default recommended installation path /opt/.
    Running the command:

    grbprobe

    returns

    info  : grbprobe version 10.0.1, build v10.0.1rc0
    HOSTNAME=localhost.localdomain
    HOSTID=64829653
    PLATFORM=linux64
    USERNAME=
    CORES=4
    CPU=Intel(R) Core(TM) i5-8350U CPU @ 1.70GHz
    CONTAINERID=host:DPB00BID
    TAG=1679922454582221864960

    Although running the command:

    whoami

    Returns my usual username.
    I am trying to do a full install, not conda.

    1
  • Werner Baak
    Gurobi-versary
    First Comment

    I have the same issue here:

    grbgetkey xxxx leads to: 

    info  : grbgetkey version 10.0.1, build v10.0.1rc0
    info  : Contacting Gurobi license server...
    error : ERROR 101: Username field cannot be blank

     

    and grdprobe works but the username field is empty: "USERNAME=".

    How can I change that? What would be the right USERNAME? 

    2
  • Martin Heistermann
    Gurobi-versary
    First Comment

    I had the same issue on my machine, which was solved by changing my locale setting (i.e., LANG and LC_* environment variables); in particular, `export LC_ALL=C` fixed the issue and gurobi detected my username.

    1
  • Luis Torres
    Gurobi-versary
    First Comment

    Hi,

    I had the same issue. I am running Gurobi 10.01 on a CentOS 8.5 machine with an academic license. It was also solved setting `export LC_ALL=C` in my .bashrc file. (Thanks Martin Heistermann)

     

    1

Please sign in to leave a comment.