Skip to main content

Gurobi 11.0 presolve behaviour

Awaiting user input


1 comment

  • David Torres Sanchez
    Gurobi Staff Gurobi Staff

    Hi Tim,

    Good to hear about some good improvements for you!

    Shouln't Gurobi be able to do this step by itself and set the Big M value accordingly to minimize the number of SOS constraints? Particularly because it worked flawlessly in Version 10. I never stumbled into this problem in the last 6 months while using Gurobi 10.0.

    Not necessarily, a smaller number of SOS constraints doesn't always mean a better performance.

    For this model, it seems that the presolve is behaving differently and by setting PreSOS1/2BigM you are forcing the reformulation at the expense of more constraints and nonzeros, this may harm other models.

    You may also want to experiment with: PreQLinearize and PreMIQCPForm.



Please sign in to leave a comment.